1

Two days ago I installed elementary OS and now I am experiencing issues with my external monitor. I'm using a Dell XPS 15 9560 with and LG superwide monitor.

Unable to disable built-in monitor

At the office I like to work on a external monitor with the laptop open and the built-in display disabled. With this setup I can use the track pad of the laptop for scrolling. That's how I did it with the previous distro (Pop!_OS) I've been using. But disabling the built-in monitor seems to be impossible with eOS, or am I wrong?

No tray nor dock after sleep

While using an external monitor, my laptop is closed. This works fine s long as the system does not go to sleep. Waking it up is a pain because it does not listen to the wireless mouse or keyboard (also Dell). Touching the built-in keyboard wakes up the system but then I have two screens, both missing the to menu bar/tray as well as the dock. The only thing I can do in this scenario is a hard reboot.

Not dock nor tray after reboot

This morning I logged in and again, no tray or dock were showing, so I did a reboot without the external monitor. But even after a reboot, they didn't show up. I had to manually launch the switchbaord (/usr/bin/io.elementray.switchboard) though the terminal to be able to access display settings, where I fiddled a bit with the settings. After rebooting the tray and dock were back (fortunately).

0

I'm facting similar issues on HP Spectre x360. Loki worked great, but Juno is terrible.

In response to Unable to disable built-in monitor, I have found a way to turn it off:

  1. Find out the display names:

    xrandr | grep conn | grep -v dis
    
  2. Disable the desired display:

    xrandr --output <display> --off
    

On my machine, first command returned:

eDP-1 connected 1920x1080+0+6 (normal left inverted right x axis y axis) 293mm x 165mm
DP-1 connected primary 2560x1440+1920+0 (normal left inverted right x axis y axis) 553mm x 311mm

Then to switch off the primary laptop built-in display I simply did:

xrandr --output eDP-1 --off

I know it is not a solution but it is a start. I am intrigued by your other problems too so it is a scenario that I will be testing next.

  • 1
    In the meantime I just use the super + P combination, every time I need to reboot or re-connect the external display, to disable the built-in monitor. The elementary OS team prioritized this issue since it affects so many users. So I'm sure a fix is in the making. – wout Oct 25 '18 at 16:31

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.