0

I'm trying to remove PPA, that has been taken down from Launchpad and none of the methods I found worked.

Specifically I'm trying to remove libreoffice/libreoffice-5-2, which was not just EOL, but completelly removed from Launchpad. Because it's no longer online, AppCentre throws warnings after opening and, more importantly, fails to check for updates after turning on my laptop. I have to check updates via terminal, AppCentre just doesn't want to do it.

I tried several methods:

  1. sudo apt-add-repository --remove ppa:libreoffice/libreoffice-5-2
  2. sudo ppa-purge ppa:libreoffice/libreoffice-5-2
  3. sudo rm -i /etc/apt/sources.list.d/libreoffice-ubuntu-libreoffice-5-2-xenial.list

None of them works, the first two complain about missing Release file, the last one doesn't seem to have effect - running sudo apt update still checks the PPA I deleted (libreoffice/libreoffice-5-2).

One extra problem is that elementaryOS doesn't have any GUI for managing sources (understandably), which would be the method I'd try on e.g. Ubuntu. And I don't want to polute my system with too many non-elementary packages anyway, especially those intended to mess with other software (I had gnome-software and gdebi before but I removed both).

One more thing: I also have now LibreOffice Fresh enabled on my system, so I would wish for a method that doesn't screw with that one.

0

Try using the Software Sources utility, just unchecking the repo in the "Other Software" tab of the app.

Software Sources in Juno

  • I'm still on loki (actually i just finished reading the new release blog post), however i think this issue will solve itself when i upgrade. Still the answer could be helpful to other users.. – jena Oct 20 '18 at 12:29

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.