4

Recently installed Juno based off recommendation from a friend. The issue I'm currently facing is my laptop (Dell XPS 13), even though I've configured to never suspend on both Plugged and Unplugged, it suspends after a period of time. Are there any logs I can provide that would help? I'd prefer to avoid having systemd do anything if there's a way to configure it via the options. It just feels like something isn't hooked up quite right.

Thank you!

  • I can confirm that this also happens on my T400 – Fabio Picchi Jan 17 at 20:03
  • same here for me on older machines, Loki did not have the problem. In Juno suspend setting simply seems to be ignored. – Otuken Jul 6 at 17:56
0

Try this:

    sudo su
    su - -s /bin/bash lightdm
    gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type
    dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type nothing

Note that if you 'sudo' instead, it won't work properly. This fixed it on my XPS 15 9560 :)

  • I left eOS not long after this. I posted a bug on GitHub that's still open. This particular fix didn't work for me in October but maybe it would now. I just can't afford to have basic functionality regress so badly without fixes. I understand it's a small team, so I moved on as I didn't have time to write code (and learn the language, honestly) to try and fix it. I'll check it out again once the bug is closed as fixed. – Mountainerd Mar 4 at 4:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.