4

I have elementary OS Juno installed on my laptop and it automatically rotates the screen to upside-down. then i have to go to display to fix this problem. but it doesn't stays normal. Sometimes later it goes to upside-down again which is frustrating. On gnome3 there is a rotation lock button but I cannot find rotation lock button on Juno.

I don't need the screen rotation, how can I disable it completely?

5

I have juno running in an HP EliteBook 8460p with the screen rotation problem when I tilt the keyboard. To stop this, this worked for me:

sudo systemctl stop iio-sensor-proxy.service
| improve this answer | |
  • Sweet and simple..! – Ajay Kumar Mar 1 at 15:29
3

Juno on Hp 8510w with screen rotation problem. I have tried: sudo systemctl disable iio-sensor-proxy.service, but command did not remove script /lib/systemd/system/iio-sensor-proxy.service

To disable it at startup, file was renamed:

sudo mv /lib/systemd/system/iio-sensor-proxy.service /lib/systemd/system/iio-sensor-proxy.service_disabled
| improve this answer | |
2

there is a rotation lock in juno available under display in the system settings.

| improve this answer | |
0

Elementary doesn't have a screen orientation setting AFAIK, but you can try the following in the terminal:

gsettings set org.gnome.settings-daemon.plugins.orientation active false

I kinda like screen rotation :)

| improve this answer | |
0

This one worked for me

xrandr -o normal
| improve this answer | |
0

This worked for me but I needed to apply at each start up:

$ sudo systemctl stop iio-sensor-proxy.service 
$ sudo systemctl disable iio-sensor-proxy.service 

-- For persistance I needed this:

$ sudo apt-get remove iio-sensor-proxy
| improve this answer | |
0

sudo apt-get remove iio-sensor-proxy solved this annoyance for me, Thank you!

| improve this answer | |
  • Your participation is much appreciated👍 Let me inform you that we love informative answers with step by step guide. Please try to post detailed information so that it is simple enough for someone with zero technical knowledge to easily understand. – Hasan Mar 9 at 12:45
-1

This worked for me:

gsettings set org.gnome.settings-daemon.peripherals.touchscreen orientation-lock true
| improve this answer | |
  • hum, side effect... lock screen is upside down. There must be other way... I will keep trying. – papimigas May 31 '19 at 8:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.