0

when i try to connect my hp PSC 1400 printer to juno, i get the error "cups missing filter warning", while in Loki everything went good. I noticed that when i try to add the PSC 1400 driver from the options, there are many drivers all with the same name.

1

try with:

sudo system-config-print

  1. -> Add
  2. -> search your printer and install
  3. -> then click secondary
  4. -> properties
  5. -> politics
  6. -> check activate and accepting jobs

Note: if system-config-print is not installed, do:

sudo apt install system-config-print
0

Have you attempted http://localhost:641/ ? I could connect my EpsonL6190 after getting the ppd.gz from the Epson support site without a problem.

0

I just went through the same thing here installing and uninstalling - printer would get detected and seem to install correctly, and then the same error after a print job, "missing filter".

I finally got it by going into CUPS and reconfiguring the printer. At the part to chose a driver, I chose a different driver than the currently selected one. For mine, there was an hpcups version and an hpijs which was the currently selected driver. Upon changing to the hpcups driver, the system prompted me that the driver wasn't found and asked to download from HP or if I had a copy locally already to use it. I selected download from HP and at this point an HP Utility popped up to select and download it (I'm guessing that this was the HP Device Manager, or hp-setup). Problem was it was asking for the root password and nothing else in order to download and install (my password wouldn't work and there was no function to use sudo). So I had to first set a root password, enter it into the HP utility and then it downloaded and carried on successfully.

At this point I'm now using a driver downloaded from HP and using the "hpcups" driver, not the default hpijs. When I printed a test page, it worked!

when you read the hplip docs, there is a part that specifically says that you need to set a root password in order for the installation to work, and I believe that this was the cause of the error. Unfortunately printing in Linux is like a foreign language to me, but hopefully this crude walk-through helps someone.
Ensure you install hplip, hplip-gui, hplip-doc.

sudo apt install hplip hplip-doc hplip-gui
0

I know this post is a bit dated, but I experienced this issue today with the latest Elementary OS and an HP Envy 5660 printer. I tried installing HPLIP but no joy.

What did work, however, was:

sudo apt-get install system-config-printer (note the 'er' on the end there).

Then:

system-config-printer

It found the correct driver right away and I was off to the races - hopes this helps someone. =0)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.