Just installed Juno. Overall a great job, elementary team should be really proud of their work!

I'm having some issues with display scaling. I have a Dell XPS 13 (3200 x 1800) and two external monitors (1920 x 1080). When I have the monitors connected, I set my display resolution to (1920 x 1080) since you can't set different scaling factors across the displays (as far as I know). This is the same setup that I had for eOS Loki where it worked properly.

In Juno, my windows and UI elements are all huge at the 1920 x 1080 resolution. I have tried all three scaling factor settings (Automatic/LoDPI/Pixel Doubled) in the elementary display settings and none of them seem to affect this at all (even after reboot). Likewise, editing the gnome window scaling factor directly in dconf doesn't appear to do anything.

The only thing I've found that works is using xrandr to set the scale to 2x2 and then back to 1x1 on all three displays. If I just set it to 1x1 without setting it to 2x2 first, nothing happens.

After I do this, everything appears at a normal scale. I tried putting my xrandr command as a custom command to run at startup, but that does not work, so I suspect something is overriding the scale after startup which would also explain why the gnome settings aren't being respected I think.

Any else having this issue or have any ideas? Is this a bug in Juno or Ubuntu 18.04? Any workarounds?

edit: Found a workaround that I'll be using for now via Gnome HiDpi.

Force disabling DPI scaling has the desired effect and is persistent.

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "[{'Gdk/WindowScalingFactor', <1>}]"

Notifications are still huge, but the setup is at least usable. This still is not ideal.

  • I wanted to switch my XPS 13's resolution to 1920x1080 because video playback on chrome is stuttering and I ran into these issues as well Commented Oct 17, 2018 at 18:55

1 Answer 1


The problem can be fixed by manipulating xrandr. You should in input these commands to double the pixels enabled in settings. Hopefully, this will fix the issue with scaling after changing resolutions.

xrandr --output DP-1 scale 2x2
xrandr --output DP-1 --scale 0.5x0.5
xrandr --output DP-1 --scale 1x1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.