5

In monitor settings at System settings, after re-ordering the screens correctly, if I want to disable the internal screen, even after disabling it the laptop screen will still be on and show Pantheon. Only after closing the lid does it disable it accordingly.

Also, after selecting secondary screen as primary, Pantheon did not move the main UI (upper panel, dock, etc) to that screen accordingly.

I'm using Intel HD Graphics 630 with Nvidia Optimus (NVIDIA GTX 1050) and NVIDIA'S proprietary drivers. I'm currently running with the NVIDIA card selected.

I haven't tested it with the Intel card selected, I'll get back to you on this. It'll probably have the same behaviour since the Intel card is the one managing the screens.

  • I can confirm that bug. I have the same situation. Positioning screen work as should but I can't turn off e-DP1 screen (laptop monitor). I use only integrated Intel HD620. – DooshPastesh Nov 18 '18 at 11:44
3

default integrated monitor is not always LVDS-1 first you should get overview of detected displays and their aliases by command

xrandr | grep " connected " | awk '{ print$1 }'

then cast

xrandr --output <here alias of your integrated monitor> --off
| improve this answer | |
  • If you noticed, I'm not using the terminal, I'm reporting a bug in the Monitor Settings GUI. Not helpful. – Emanuel Vitorino Jan 4 '19 at 16:52
  • bug persists, no doubts there. – Amphyby Jan 5 '19 at 17:51
1

Same here. Don't know what caused the bug. But for the moment I just use xrandr to disable the laptop monitor:

xrandr --output LVDS-1 -off

"LVDS-1" is the internal monitor for me. You can identify it by just running xrandr.

Reference

| improve this answer | |
0

Exactly the same here, see Dual display issues on HP laptop? ... :| The worst thing about this really is that, no matter what I do, I can't get the unlock screen to appear on the primary display.

| improve this answer | |
0
xrandr --output LVDS-1 -off

solved for me, but it's sad that it doesn't work for the Elementary OS system itself.

edit:when I restarted the computer the problem came back

| improve this answer | |
0

xrandr --output LVDS-1 -off

While this isn't ideal, it can be made semi-permanent by going to

System Settings>Applications>Startup and adding the appropriate string to activate on system start.

enter image description here

I use this solution to prevent my second monitor from starting until I need it. I feel like the underlying problem has something to do with xorg, gtk, or something else upstream that the eOS team is somewhat at the mercy of.

Good luck!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.