3

For some reason, in order to switch my wallpaper, I need to reboot my pc every time, and if I am not doing that, it will just mark the wallpaper I chose as "selected", but won't actually change until I reboot.

Is there any solution to that?

2
  • Same here... Workaround: logout - login
    – redbaron
    Nov 11, 2018 at 16:17
  • Also a problem for myself. And having to logout and back in is not a tenable fix. Nov 13, 2018 at 17:09

1 Answer 1

3

The same problem was solved for Loki previously.

You have to restart (or at least reload) Gala to change the wallpaper. To do that, you can type or paste the following into Terminal:

killall -HUP gala

The -HUP flag tells the command to basically "Hang-UP" the gala process, which makes it restart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.