The action area buttons have gone missing from my file chooser dialog. I am unable to take action or close the dialog. How can I get the buttons back?

Missing Buttons

4 Answers 4


This seems to be an issue with a Gtk setting being changed somehow. There is a setting to make dialogs use buttons up top in the headerbar instead of down below. This is useful in other environments like GNOME, but it breaks dialogs in elementary OS as you can see here.

The solution is to create an xsettings override that will set the value to false (its default value). This is easier than it seems and can be done with the following command in Terminal:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/DialogsUseHeader': <0>, 'Gtk/ShellShowsAppMenu': <0>, 'Gtk/DecorationLayout': <'close:menu,maximize'>}"

This command uses gsettings to add 'Gtk/DialogsUseHeader':<0> (the "0" represents "false") to your list of xsettings overrides. If you already have other overrides set up, make sure you modify the command so that those are not overwritten.

  • 1
    this is going to be added to the final release of Loki?
    – Alexandr
    Commented Jul 11, 2016 at 19:47
  • @Alexandr, this has already been done, if I'm not mistaken.
    – png2378
    Commented Jul 12, 2016 at 12:42
  • 1
    the bug is still there, just installed Loki stable.
    – Rho
    Commented Dec 30, 2016 at 14:33
  • 2
    the bug is still there, just installed Loki 4.1
    – Rho
    Commented Jun 12, 2017 at 15:57
  • The same here. Installed elementaryos-0.4.1-stable.20170814.iso and was affected by the same. Has this been reported upstream?
    – orschiro
    Commented Jan 25, 2018 at 8:04

I think I know how my gsettings got borked. I use IMEs for Japanese and Chinese, and I've had to cycle through fcitx/ibus a few times. The override for input module had been put in place of the override for dialog headers (probably a copy-pasta mistake).

To make sure you won't lose any overrides you might need, check that key before setting it:

gsettings get org.gnome.settings-daemon.plugins.xsettings overrides

In my case:

{'Gtk/DialogsUseHeader': <0>, 'Gtk/IMModule': <'fcitx'>, 'Gtk/ShellShowsAppMenu': <0>, 'Gtk/DecorationLayout': <'close, :menu,maximize'>}

  • Thanks, Que! Your answer is really helpful, i have solve this problem according to your way. I am also using FCITX as chinese input method, I think this is why Daniel's way didn't work when I tried it first.
    – ultra
    Commented Dec 1, 2016 at 8:19
  • This can be a comment below the accepted answer
    – Anwar
    Commented Jul 20, 2019 at 14:58

Hoping that I can provide some answers for other who were in my situation trying to get HiDPI monitors auto scaling correctly. At work I use a 2015 MacBook Pro with some 2K monitors and was experiencing the buttons being cut off when I used the Gnome-Tweak-Tools to set my scaling factor. This worked but I had to manually set the scale whenever I moved connected or disconnected my laptop.

Experimenting a bit I found a setup that worked perfectly for me using Daniel's explanation. This solution automatically scales the laptop accordingly based on the monitors connected (so I can see the HiDPI scaled 2x) and also brought back the missing buttons.

[~] gsettings get org.gnome.settings-daemon.plugins.xsettings overrides
{'Gtk/DialogsUseHeader': <0>, 'Gtk/DecorationLayout': <'close:menu,maximize'>}

[~] gsettings get  org.gnome.desktop.interface scaling-factor
uint32 0

Setting the scaling-factor to zero is the default which should preform auto scaling for you. If you've been manually adjusting scaling like I have, just double check this. Hopefully I've included enough keywords to help people who might have been seeing this issue on HiDPI screens.

  • Are you sure you've posted this answer under the right question? It seems to be about HiDPI screens, while the issue is about choose dialogs and it's buttons. Commented Nov 27, 2017 at 13:28
  • As stated in the answer, this resolves the button problem and the HiDPI issue I was having (both are related, thus this answer is most helpful).
    – user13593
    Commented Feb 3, 2018 at 19:38

I am using Elementary OS Loki. I used "Tweak Tool", version 3.18.1 from AppCenter, to tweak some settings. The tool overwrites gnome xsettings overrides file without including prevous overrides. May or may not be a bug in that tool. When I use official tweak tool from 'System Settings->Personal->Tweaks->Appearance->General->Theme Settings' to toggle some setting, say 'Show Gnome Menu", the xsettings overrides get fixed.

Before the fix I had xsettings overrides set to:

$ gsettings get org.gnome.settings-daemon.plugins.xsettings overrides
{'Gtk/ShellShowsAppMenu': <0>}

After the fix:

$ gsettings get org.gnome.settings-daemon.plugins.xsettings overrides
{'Gtk/DialogsUseHeader': <0>, 'Gtk/ShellShowsAppMenu': <0>, 'Gtk/DecorationLayout': <'close:menu,maximize'>}
  • You are referring to the GNOME Tweaks tool. elementary OS is not using GNOME as it's desktop environment but a custom developed called Pantheon. You shouldn't use GNOME Tweaks on elementary as it can cause problems like this one. Commented Dec 19, 2018 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.