0

I don't have any sound, only dummy output which doesn't work, and following the Ubuntu guide for troubleshooting sound, I get stuck at loading the modules.

https://help.ubuntu.com/community/SoundTroubleshooting

(This is the guide I'm trying to follow)

To preface this, I have had sound working before on fresh install and it seemed to stop working when I shut my laptop lid. And in my quest to fix the issue, I have updated to kernel 4.18.8 using ukuu which appears to work fine other than the sound still not working.

So, when I get to step 4 of the guide, I get no soundcard found. Then, when I go to check if the modules are installed (step 5 of the guide), I get a normal result.

However, using alsa info to give me an output, it appears to not have any modules actually loaded.

http://www.alsa-project.org/db/?f=d1320e6df212a41f4dccda8b33ff5fe13c4adc86

That is the output of alsainfo as suggested by a number of forums for sound troubles. via this link:

https://wiki.ubuntu.com/Audio/AlsaInfo

Strangely, to add to this, I tried sudo alsa force-reload and I do actually get an output:

Unloading ALSA sound driver modules: snd-soc-skl snd-soc-skl-ipc snd-soc-sst-ipc snd-soc-sst-dsp snd-hda-ext-core snd-soc-acpi snd-soc-core snd-compress snd-pcm-dmaengine snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-dummy snd-seq-oss snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.
Loading ALSA sound driver modules: snd-soc-skl snd-soc-skl-ipc snd-soc-sst-ipc snd-soc-sst-dsp snd-hda-ext-core snd-soc-acpi snd-soc-core snd-compress snd-pcm-dmaengine snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-seq-dummy snd-seq-oss snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-seq-device snd-timer.

Which is strange, because if there are no modules loaded, what is it unloading and loading...

(Maybe that's just me being a noob, but that seems odd).

Would greatly appreciate help.

0

If sound works after sudo alsa force-reload
use alsa-info.sh again to see working configuration

If modprobe options for snd_hda_intel are changed from:

snd_hda_intel: probe_mask index=1

snd_hda_intel: model=auto

You may be able to apply those changes in /etc/modprobe.d/alsa-base.conf

If ALSA can identify the correct audio codec, may be an appropriate model option listed here

  • It seems to be working now after dumping the pulse config. alsa-info now outputs: alsa-project.org/db/?f=edfe85df50ee64c180051a6cb410eff3c27e9ba9 – Human_Cruces Sep 25 '18 at 1:14
  • I note that both of those modprobe options no longer present. Presume you may have had update for Pulseaudio to cause loss of sound? update sometimes needs home folder cookie reset rm ~/.config/pulse/cookie – nik gnomic Sep 25 '18 at 10:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.