sudo apt-get install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.2.2-5ubuntu0.16.04.4) but it is not going to be installed
       Depends: libfreerdp-client1.1 (>= 1.1.0~beta1+git20130629) but it is not going to be installed
       Depends: libfreerdp-core1.1 (>= 1.1.0~beta1+git20130629) but it is not going to be installed
       Depends: libfreerdp-gdi1.1 (>= 1.1.0~beta1+git20130629) but it is not going to be installed
       Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
                libgles2
       Depends: libqt5x11extras5 (>= 5.1.0) but it is not going to be installed
       Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
       Depends: libsdl1.2debian (>= 1.2.11) but it is not going to be installed
       Depends: libva-drm1 (>= 1.1.0) but it is not going to be installed
       Depends: libva-x11-1 (>= 1.0.3) but it is not going to be installed
       Depends: libvlccore8 (>= 2.2.0) but it is not going to be installed
       Depends: libvncclient1 (>= 0.9.10) but it is not going to be installed
       Depends: libxcb-composite0 but it is not going to be installed
       Depends: libxcb-xv0 (>= 1.2) but it is not going to be installed
       Recommends: vlc-plugin-notify (= 2.2.2-5ubuntu0.16.04.4) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 2.2.2-5ubuntu0.16.04.4) but it is not going to be installed
       Conflicts: vlc:i386 but 2.1.4-1 is to be installed
 vlc:i386 : Depends: vlc-nox:i386 (= 2.1.4-1) but it is not going to be installed
            Depends: libaa1:i386 (>= 1.4p5) but it is not going to be installed
            Depends: libc6:i386 (>= 2.15) but it is not going to be installed
            Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not going to be installed
            Depends: libfreetype6:i386 (>= 2.2.1) but it is not going to be installed
            Depends: libfribidi0:i386 (>= 0.19.2) but it is not going to be installed
            Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
            Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                     libgl1:i386
            Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not going to be installed
            Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
            Depends: libsdl-image1.2:i386 (>= 1.2.10) but it is not going to be installed
            Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not going to be installed
            Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed
            Depends: libtar0:i386 but it is not going to be installed
            Depends: libva-x11-1:i386 (> 1.3.0~) but it is not going to be installed
            Depends: libva1:i386 (> 1.3.0~) but it is not going to be installed
            Depends: libvlccore7:i386 (>= 2.1.0) but it is not installable
            Depends: libx11-6:i386 but it is not going to be installed
            Depends: libxcb-composite0:i386 but it is not going to be installed
            Depends: libxcb-keysyms1:i386 (>= 0.3.9) but it is not going to be installed
            Depends: libxcb-randr0:i386 (>= 1.1) but it is not going to be installed
            Depends: libxcb-shm0:i386 but it is not going to be installed
            Depends: libxcb-xv0:i386 (>= 1.2) but it is not going to be installed
            Depends: libxcb1:i386 (>= 1.6) but it is not going to be installed
            Depends: libxext6:i386 but it is not going to be installed
            Depends: libxinerama1:i386 but it is not going to be installed
            Depends: libxpm4:i386 but it is not going to be installed
            Depends: zlib1g:i386 (>= 1:1.2.3.3) but it is not going to be installed
            Recommends: vlc-plugin-notify:i386 (= 2.1.4-1) but it is not going to be installed
            Recommends: vlc-plugin-pulse:i386 (= 2.1.4-1) but it is not installable
            Conflicts: vlc but 2.2.2-5ubuntu0.16.04.4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
  • Hello and welcome to this site! Have you tried what apt-get is telling you: "Try 'apt-get -f install' with no packages"? – Mr Shunz Sep 12 at 13:28
  • yes Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... failed. The following packages have unmet dependencies: qbittorrent : Depends: libboost-system1.62.0 but it is not installable Depends:e @MrShunz – karmvir singh Sep 12 at 13:40
  • but didn't worked – karmvir singh Sep 12 at 13:41
sudo apt update
sudo apt install -f
sudo dpkg --configure -a
sudo apt install vlc

these commands in sequence as desсribed should work.

P.S.: Just checked on my eOS 0.4.1 - simply works.

Not really a solution but a workaround in case nothing else works:

You can also install VLC via Snap Store and Flathub and qBittorrent via Flathub.

Still, something seems to be seriously wrong with your system, so you should try to fix it instead of just ignoring it. Hopefully other people can help you find a solution for it.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.