0

Created a bug report for this already, but hoping that someone can advise me if it's just a setting that I need to change in the lock screen.

If the lock screen or greeter is active, it prevents my display from going to sleep. Instead, if you lock it, after a few moments the screen will turn black with the backlight still on and the display still awake (constant blue LED on the monitor).

I am able to get the display to sleep with xset dpms force off, but if "Lock when screen turns off" is active the behaviour is that the screen will turn off for roughly one second (blue LED flashing), then turn back on (red LED), and then display the lock screen (with constant blue "on" LED). Eventually the screen will turn black with backlight on after a few moments of showing the lock screen.

My graphics card is an NVIDIA GTX 750 Ti, current graphics drivers are from the nvidia-driver-390 series, driver: 390.48-0ubuntu3

The monitor is a Achieva Shimian QH270 27" LED 2560x1440. Reported to Switchboard's Displays module as an Aculab Ltd 27". I had some trouble getting this monitor to work with Xorg in earlier versions, but now it works at full resolution with an xorg.conf file.

I'm fairly certain that this is an issue with the , as the monitor turns off without it running and it doesn't happen in other distros or flavours of Ubuntu.

Kernel:Linux hostname 4.15.0-33-generic #36-Ubuntu SMP Wed Aug 15 16:00:05 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/lsb-release
DISTRIB_ID=elementary  
DISTRIB_RELEASE=5.0
DISTRIB_CODENAME=juno
DISTRIB_DESCRIPTION="elementary OS 5.0 Juno"
0

Check the greeter config in /etc/lightdm/io.elementary.greeter.conf

There is a line (hashed by default) triggering monitor sleep:

#screensaver-timeout=60

Unhashing it should enable screensaver. You can change the trigger time (4 digits max - more crashes the greeter).

Ultimately check your /etc/X11/xorg.conf file. X server has default 10 min screen off hardcoded. U can control it in (I disabled all):

Section "Monitor"
    Option "DPMS" "false"
...
Section "ServerLayout"
...
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime"     "0"
    Option "BlankTime"   "0"
...

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.