0

I installed Elementary Loki a week ago and so far I'm liking it quite a bit. It's my first time running a Linux based OS.

Nonetheless, I'm experiencing an annoying problem. Once or twice a day the display colors became messed up. I might be watching a video or browsing the web and suddenly the colors change and text becomes difficult to read. If I logout or suspend the session and come back it's fixed (until it happens again...).

Screenshots don't show the issue. When I look at them in a normally colored screen they show regular colors. (I took some photos with my phone that I'm attaching; sorry for the bad quality).

I can't seem to find any correlation between this and the way I'm using the OS (specific apps, time running, CPU usage, etc).

I'm running Elementary Loki on a recently bought refurbished HP Elitebook 820 G1 (i5-4300U, 8GB RAM, new 240GB Kingfast F6 PRO SSD, no dedicated GPU).

The screen color issue did not appear on any other OS I've tried on this laptop but Elementary is the only one I've used for more than 10 or 15 minutes. I've only booted into Windows 10 (it came with the laptop) in order to download the Elementary iso and I've tried maybe a dozen other Linux based OS in live session for about 5 to 10 minutes each.

I've searched online for similar issues with Elementary (or Ubuntu) and couldn't find any reports.

Does anyone have any idea of what I can do to fix this? Please bear in mind that I don't know much about computers.

I'm sorry for the long exposition. Thanks in advance for your time and ideas.

João enter image description here enter image description here enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.