0

Using GRUB to dual boot between elementary OS and Windows 10. After using elementary and rebooting to Windows 10 the time is mysteriously 4 hours off. Just started happening a few months ago. So, every time I reboot to Windows 10 after using elementary I have to reset the time in Windows. Reboot to elementary after using Windows and the time doesn't change. Anyone else seeing this happen to them?

  • superuser.com/questions/250643/… there is the answer on your question :) – Amphyby Aug 30 '18 at 9:57
  • Yes I experienced the same problem. Even after changing the time manually I still have the same result. At this point I am not too much troubled looking for a solution for a system that doesn't really foresees any other operating system apart from that only one. I would suggest not to worry about this strangeness that inhabits Windows as platform since its origins – Vincenzo Nardelli Aug 31 '18 at 13:47
1

As user Amphyby commented, this is a known situation when you install a distro in dual boot configuration with Windows.

Basically what is happening is that Windows reads the computer time as local time, while elementary reads it as UTC.

Easiest way to solve it is to just run this command in the terminal to set elementary to also read time as local:

timedatectl set-local-rtc 1

0

check the windows time zone if it is matched with Linux location you set. windows has this set time automatically feature . and maybe your linux distro is setting the time based on location too

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.