1

When I press ctrl + shift + e something strange happens and I can't write nothing anymore for a few keystrokes.

enter image description here

In the gif above I press ctrl + shift + e multiple times. You can see that the first letter is lower case and after upper case. Some strokes later everything is removed. After I try to remove the e with ctrl + z and the same thing happens.

This problem affects all apps that I tried (scratch, vscode, chrome, terminal etc).

I've looked in settings to see if is a shortcut for something, but didn't find id. I'm using juno beta release.

  • I think it's a ubuntu problem. I'm using KDE neon now and it has the same problem :/ – Luís Henrique Faria Dec 8 '18 at 18:00
0

I guess I found solution:

export GTK_IM_MODULE="gtk-im-context-simple"

and then run vscode (or another app) from the same shell. If that doesnt work try this: export GTK_IM_MODULE="xim"

As for me second variant works well.

To save this for all application put line into /etc/environment, or per-user in ~/.gnomerc. (The export command doesn't go in those files, just a new line with GTK_IM_MODULE="xim" or GTK_IM_MODULE="gtk-im-context-simple".)

Original: https://superuser.com/a/1334194

  • ` export GTK_IM_MODULE="xim"` did the trick for me. Thanks! – Luís Henrique Faria Sep 27 '18 at 19:55
  • update: that solved the vscode problem, but created another one. I can't use accents anymore (my language is portuguese and we use accents). – Luís Henrique Faria Sep 27 '18 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.