0

I'm switching to Linux to save my old 2010 Macbook, since it is almost unusable with the newer versions Mac OS.

I just finished setting up Elementary OS, but the wifi will not work. During setup, I was asked to configure a network, and I entered my Wifi network and password. However when I actually log in, there is no network connection.

When I go to System Settings, Ethernet is the only available option. Under "Edit connections..." I can see my wifi network, as configured, but I have no way to connect to it.

I followed the instructions in this thread WiFi on MacBook Pro (12,1 - Early 2015) but no luck. It looks like the firmware linked to in there is for Broadcom chips in newer Macs (2013 onwards). Do I need a different driver?

By th way, for some reason, plugging in the ethernet doesn't do anything, either.

I would really appreciate any help. :)

  • any news on this issue ? Did you manage to fix it. I have the same exact issue. – Danny991 Oct 6 '19 at 9:34
1

There are so many conflicting posts on getting WiFi working on MacBooks, so after spending hours of trial and error, featuring completely reinstalling Elementary OS and starting over several times, I’m posting what worked for me. I hope it’s useful to someone!

My MacBook Pro is mid-2010 (7,1). Make sure your WiFi module is the same Broadcom as mine by first issuing this command in Terminal:

 lspci -nnk | grep 14e4:

Check to make sure the output shows the Wireless LAN Controller is [14e4:432b], like mine. If yours is different it may need a different procedure to get the WiFi working.

I found the answer that worked here:

https://askubuntu.com/questions/1188364/wifi-not-discovering-networks-ubuntu-18-04-macbook-pro-mid-2010

These are the instructions from that post that worked for me, edited to show what I had to do that was different for Elementary OS:

  • open APPCenter, lick on Installed, then uninstall the 'bcm-kernel-source' package

    • make sure that the 'firmware-b43-installer' and the 'b43-fwcutter' packages are installed

    (terminal: sudo apt-get install firmware-b43-installer followed by sudo apt-get install b43-fwcutter)

  • type into terminal:

    cat /etc/modprobe.d/* | grep '8180|acx|at76|ath|b43|bcm|CX|eth|ipw|irmware|isl| lbtf|orinoco|ndiswrapper|NPE|p54|prism|rtl|rt2|rt3 |rt6|rt7|witch|wl

    (you may want to copy this) and see if the term 'blacklist bcm43xx' is there. (it was for me)

  • if it is, cd /etc/modprobe.d/

sudo gedit blacklist.conf

(I had to install gedit first: sudo apt-get install gedit)

put a # in front of the line: blacklist bcm43xx

then save the file (I was getting error messages in the terminal about not being able to save, but it actually did save properly)

  • reboot

  • sudo iw reg set "REGION"

  • reboot

IMPORTANT: "REGION" should be replaced by the ISO alpha-2 2-character country code where you're using the computer, which can be found at this Wikipedia entry (scroll down): https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2

This is important because the Broadcom WiFi in the computer can operate on a wide range of frequencies, and each country regulates what can be used for WiFi by devices in their country. If you don't set this correctly, and reset it if you travel to a different country, it is possible (not all that likely, but possible) that your computer could cause interference to completely different wireless services. (As a former frequency coordinator for the Society of Broadcast Engineers this is all the more important to me.)

And thanks for fixing the formatting!

| improve this answer | |
  • Thanks for the detailed answer! I notice in your lspci command you have 1434 and further on you say 14e4, could you check which of these is correct and update your answer? – David Hewitt Jun 9 at 10:59
  • Thanks for catching that, David – not sure how that happened. It's been corrected. – Andy Funk Jun 10 at 13:13
0

I haven't tried Elementary on Apple hardware, but this sounds to me like there's probably a missing driver. Not sure in Juno if there's somewhere equivalent to Ubuntu's "Additional Drivers" in Software Sources? A little digging suggests that you can run sudo ubuntu-drivers autoinstall and that should do the same thing the Additional Drivers dialog does.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.