0

TL;DR Black screen after resuming the suspend (from closing the lid), by opening the lid.

But works fine if suspended by other method.

TL;andpleasehelpme I've just installed and tweaked with Elementary OS 0.4.1 Loki for a few days now. Planning to use this as my primary OS, but suspend is not working properly for me.

As for other many issues I've encountered, I've managed to find a solution, but I can't seem to get suspend to work properly.

I've updated my kernel to 4.17.13 and NVIDIA drivers to 390.77

Nothing seems to work. After testing a bunch of ways and playing around, it seems like if I suspend using the power button or using the power option, resuming the machine by clicking the power button again would wake the machine with no problem. And this is all while the lid is open (obviously).

(Another thing I realised is that if I press any key while the machine is suspended, the keyboard will lit up but the machine will still be suspended. Is this normal?)

Now the issue is when I close the lid, and it is suspended, and opening up the lit. The machine will resume and I greeted with.... well, nothing! I can Ctrl + Alt + F1, which proves that the machine is resumed. And to make it worst, it forces itself back to sleep (looping again and again if I keep waking it up to see the black screen).

Here's the relevant syslog (log too long, can't fit in the textbox). https://gist.github.com/muazamkamal/b9ed4596e32d2c7bec75f54dc4de4f42

0

Did you ever managed to solve this? Mine is Dell Latitude E7250 and started to have similar issues recently as well. The root partition becomes read-only after resume from suspend.

  • I switched to Pop_OS! (a different distro), but the problem still persist although a bit different. To go into details, I suspect it's something to do with the hardware of my laptop, specifically the lid. I'm using a Razer Blade 14 (2015). When opening the lid (from sleep), the status from "closed" doesn't change to "open". And that might be the root of the issue. How do you solve the "read only" issue? I should give that a try. – MuazamKamal Sep 22 '18 at 8:14
  • I haven't fixed it yet. For now i prevent the root partition from remounting as read-only because that happens after i resume from sleep which causes this issue. Haven't found what's causing it. Tried a few of the tips on 01.org/blogs/rzhang/2015/best-practice-debug-linux-suspend/… but no go. – hezral Sep 23 '18 at 11:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.