0

i am using hp notebook and i switched from windows to elementary OS and don't find support for AMD graphics card please give driver update hope you will work on my request

  • There's already support for amd cards. If you need help configuring your laptop, open a terminal and update your question with the output of lspci | grep VGA – Maccer Jul 28 '18 at 11:02
0

It is necessary to know more information about your system, but I will tell you what worked in my case:

download the driver from the official website of amd. After that unzip and edit the files amdgpu-install and amdgpu-pro-install. In line 90 change ubuntu by elementary and save the change.

If you do not do that, it will say OS not supported.

Depending on the version of the driver you will also need to edit the system file / etc / os-release on line 6 of VERSION_ID = "0.4" to VERSION_ID = "16.04" if you are using Eos loki (open "files" with administrator privileges for to be able to make the change).

After that open the folder where the driver is with the terminal and put there:

./amdgpu-pro-install -y

(this installs Base kernel, Accelerated graphics, Multimedia table, Pro OpenGL, Pro Vulkan, Pro OpenCL).

After installing everything correctly edit the system file / etc / os-release again, on line 6 of VERSION_ID = "16.04" to VERSION_ID = "0.4" to leave that file as it was before.

Sorry bad english.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.