1

After installing Juno, even after trying it from the live CD with the wifi up and running successfully, at the first startup of Juno, wifi is not installed on MBP 6,1

0

I had that too with my MBPr 11,5. You have to run - sudo modprobe brcmfmac to load wireless. Run it from the terminal app. Keep in mind that that is my wireless module to load. Yours might be different.

  • I believe it is. Thank you for the indication for a MBP11,5 - there should be a MBP team for ElementaryOS support on StackExchange. The solution for a MBP6,1 is different, posted it for the users info. – Lurch Nov 15 '18 at 10:33
0

I posted this question for the Juno Beta, a little annoyed I had to search for a network LAN cable to finish the install - again - that the problem is still not solved in the stable Juno version. Anyway: here's the comprehensive fix to this issue:

I fixed it: wifi adapter is a Broadcom BCM4313. First I disabled it in Software Center -> Edit -> Software Sources -> Additional Drivers. Then I used

sudo apt-get purge bcmwl-kernel-source

to get rid of the driver. And

sudo apt-get install b43-fwcutter firmware-b43-installer

after underbroken install

apt-get update --fix-missing
sudo dpkg -configure -a
sudo apt-get install -f

if not working

sudo apt-get purge b43-fwcutter firmware-b43-installer

and redo the above to install a new one. After a reboot it worked again.

However please note that installing Synaptic package manager brought to my attention that there's a legacy driver that can be installed as well, for on my MBP6,1 the driver isn't working satisfyingly on a permanent basis: it bugs in the following way: the wifi signal indicator indicates no signal, another wifi appears selected than the one I'm connected to, and the connection interrupts. A simple cutting and then reinstating the connection from the wireless menu solves the problem for a short while (a minute or so) and then it restarts. Installing the legacy driver through Synaptic seems to solve the problem. The package name is: firmware-b43-legacy-installer

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.