Dropbox icon is missing in Juno, and the Loki workarounds (Dropbox icon missing in Loki) doesn't work anymore.

  • i'd tried pure dropbox installation and the workaround working on loki, nothing happened, i'd also tried "elementary-indicators" workaround, now i've franz and skype tray icon working(before not), but dropbox still remain the problem. no solution found yet :( Commented Nov 26, 2018 at 17:06
  • try this (only tested on juno) github.com/isneezy/wingpanel-indicator-dropbox Commented Nov 27, 2018 at 6:31
  • ok! i've solved! i dont know how, but it works. first i remove all dropbox installation, i remove dropbox-nautilus. on second thing i'd made, the old loki workaround "elementary-dropbox" uses some iconpacks, so i found the PPA and install all icon-themes(moka, paper, and many more).... after i restart the "elementary-dropbox" installation without any tray.... i shutdown my laptop, the nex day i poweron it, and tadaaaaa! the magic! so i think, it is a combination of some iconpack, elementary-dropbox workaround and Wingpanel-indicator-ayatana workaround, thats all Commented Nov 28, 2018 at 11:20
  • PS i'd also edited /usr/share/applications/dropbox.desktop changing the line Exec like this #Exec=dropbox start -i Exec=env XDG_CURRENT_DESKTOP=Unity QT_STYLE_OVERRIDE='' dropbox start -i that's all id' made. Commented Nov 28, 2018 at 11:28
  • PSS this work for 2 users, on my third user dont..... i dont know why..... Commented Nov 28, 2018 at 14:59

3 Answers 3


Try this workaround from Matt Harris. I've tested with Skype and it works.


  • 1
    This did not work for me in Juno. The old answer still works perfectly though: elementaryos.stackexchange.com/a/32/9
    – Gabriel
    Commented Oct 23, 2018 at 13:28
  • Update: the old answer no longer works apparently. This is extremely frustrating.
    – Gabriel
    Commented Mar 27, 2019 at 15:07

This thing was very annoying to me and I decided to create this simple native wing-panel indicator. It is not perfect but it works very well and I'm still improving, you can try it!


enter image description here


the "problem" is Wingpanel-indicator-ayatana.

see this: Elementary OS 5.0 and Hardware Sensors Indicator

is applicable to almost all wingpanel "problems"

This is because the creators of elementary os think bigger than steam, dropbox, skype, mega, "several famous applications commonly used by users", etc.

Have a nice day.

  • correctly identified the issue and (implicitly) provided (a link to) a solution. I came across another answer that does the same thing but in a more concise manner: Answer for re-enabling missing wing-panel icons
    – user10425
    Commented May 4, 2019 at 16:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.