This morning, after a regular system including security update, my wifi driver was knocked off, no wifi appeared in network anymore

sudo lshw -C network returned:
description: Ethernet interface product: NetXtreme BCM57765 Gigabit Ethernet PCIe vendor: Broadcom Corporation physical id: 0 bus info: pci@0000:02:00.0 logical name: enp2s0 version: 10 serial: c8:2a:14:03:4c:09 capacity: 1Gbit/s width: 64 bits clock: 33MHz capabilities: pm msi msix pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.137 firmware=57765-v1.37 latency=0 link=no multicast=yes port=twisted pair resources: irq:16 memory:b0400000-b040ffff memory:b0410000-b041ffff *-network UNCLAIMED description: Network controller product: BCM4331 802.11a/b/g/n vendor: Broadcom Corporation physical id: 0 bus info: pci@0000:03:00.0 version: 02 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list configuration: latency=0 resources: memory:b0600000-b0603fff

So I followed those instructions, but my wifi driver still wont work:

b43 - No Internet access

If you do not have any other means of Internet access from Ubuntu, then you will have to download the firmware from another computer with Internet access, from an existing OS on another partition, or before you install Ubuntu. You will also need the b43-fwcutter package which is usually included on the install media or can be downloaded from the official online repositories.

Install the b43-fwcutter package. This is usually located on the Ubuntu install media under /cdrom/pool/main/b/b43-fwcutter/ or you can download the binary '.deb' package by following the links on launchpad.

Double click on the package to install or in a Terminal issue the following commands:

cd /cdrom/pool/main/b/b43-fwcutter/
sudo dpkg -i b43-fwcutter* 

On a computer with Internet access, download the required firmware file:

b43legacy - http://downloads.openwrt.org/sources/wl_apsta-
b43 (12.04 Precise Pangolin) - http://mirror2.openwrt.org/sources/broadcom-wl-
b43 (14.04 Trusty Tahr) - http://www.lwfinger.com/b43-firmware/broadcom-wl-5.100.138.tar.bz2

For the latest information on what files to download see http://wireless.kernel.org/en/users/Drivers/b43#Other_distributions_not_mentioned_above and http://wireless.kernel.org/en/users/Drivers/b43/developers .

Copy the downloaded file to your home folder. Open a new Terminal and use b43-fwcutter to extract and install the firmware:


sudo b43-fwcutter -w /lib/firmware wl_apsta-

b43 (12.04 Precise Pangolin)

tar xfvj broadcom-wl-
sudo b43-fwcutter -w /lib/firmware broadcom-wl-

b43 (14.04 Trusty Tahr)

tar xfvj broadcom-wl-5.100.138.tar.bz2
sudo b43-fwcutter -w /lib/firmware broadcom-wl-5.100.138/linux/wl_apsta.o

Restart the computer or reload the b43/b43legacy module as outlined in the Switching between drivers section below (replace b43 with b43legacy where appropriate). 

The problem is that the b43-cutter install worked, even updated while I connected over cable, but the b43 driver install went through once but was not recognized by the system, still in the same state.

  • I found this post solved the issue
    – Lurch
    Commented Jul 3, 2018 at 14:06
  • My system then more recently rebooted to a strange state, where the wifi adapter was in the state of a cable (!) interface, but running the commands of the above post once again solved the issue.
    – Lurch
    Commented Jul 6, 2018 at 0:54


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.