0

I'm running the latest, fully-updated version of Loki dual-booting with Windows 7 on my laptop. Loki loads and boots wonderfully fast, but I cannot print at all. My HP Envy 7640 works correctly under Windows and is detected as my default printer under Loki by the default manager. However, when I send it a print job from Libre Office Write, for example, the printer's LED display says "Printing" and the animated spinner turns indicting "in progress" but nothing else happens. The job shows as "completed" in the printer manager app.

As an experiment, I installed HP's proprietary driver and GUI using "sudo apt install hplip-gui". The HP app is supposed to give the user full-featured control of support HP printers under Linux. It seems to work to a limited degree. For example, it accurately reports the ink levels. However, printing still fails to produce any printed output. In fact, the mechanisms of the printer do not initiate as is typical of a print job in progress. No "THUNK" or humming, just silence. The HP GUI says the job is in progress. I ran the HP diagnostics app, which reports a number of missing drivers and dependencies. One of them, CUPS, was reported as INCOMPATIBLE and was also reported as missing or not running. Consequently, I tried reinstalling CUPS, but apt-get install returned "cups is already the newest version (2.1.3-4ubuntu0.4)." Apparently, HPLIP is not supported in ElementaryOS.

HP printers are the most widely supported printers in the Linux world. Why can't I print using Loki?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.