3

I'm having real trouble connecting to my own network.

I can find the network (SSID) and enter the password just fine, but it can't connect from there. It keeps saying I'm disconnected. Tried everything I know of (forgetting the network, restarting modem etc.), but it seems more software/driver related. And I'm a noob on that part...

Internet via cable works just fine by the way. I already tried to update/upgrade everything via apt-get, but that didn't fix the problem.

I'm just not sure how to proceed from here. :(

p.s. I'm at work at the moment, so replies may take a bit.

Update

Here's de update after running lshw -c network:

   *-network               
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: eth0
   version: 10
   serial: e0:3f:49:c2:ba:2b
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
   resources: irq:60 ioport:e000(size=256) memory:f7d04000-f7d04fff memory:f7d00000-f7d03fff

   *-network
   description: Wireless interface
   product: AR9485 Wireless Network Adapter
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlan0
   version: 01
   serial: 6c:71:d9:d4:74:9d
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
   configuration: broadcast=yes driver=ath9k driverversion=3.16.0-45-generic firmware=N/A ip=192.168.1.16 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   resources: irq:19 memory:f7c00000-f7c7ffff memory:f7c80000-f7c8ffff

I do have WiFi now while the adapter is not connected. I just needed to select my network and it worked directly... So it still might be power management somehow?

Just copied my syslog to Pastebin: http://pastebin.com/RTLHFBQk

  • Make sure you've selected proper security settings for your connection, such as cypher(AES\TKIP) and authentication method(WPA/WPA2/...) – V_Pavel Aug 26 '15 at 12:28
2

Please update your post with the output from lshw -c network as this will provide us with information regarding your WiFi device and driver in use. Also examine and provide any information you can gleam (or the entire contents on somewhere like pastebin) from the commands dmesg and cat /var/log/syslog relating to your WiFi device (usually called wlan0)

Update 1:

Thanks for the extra info. The lshw command tells us the chipset of your WiFi device is an Atheros AR9485 and is using the ath9k driver. You even have an IP so I presume this output was after you got it to connect?

I don't see anything obvious in your syslog. Did you gather this info immediately after a failed connection?

NetworkManager[873]: nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted

The above message does appear often, though from what I can see it isn't really an issue and this logging has been patched out of recent versions of network-manager anyway.

Here's a couple of common fixes for ath9k driver issues you could try. I suggest just testing with the temporary methods.

Disable Hardware Encryption

Temporary

sudo modprobe -r ath9k
sudo modprobe ath9k nohwcrypt=1

Permanent

sudo touch /etc/modprobe.d/ath9k.conf
sudo scratch-text-editor /etc/modprobe.d/ath9k.conf

Add options ath9k nohwcrypt=1 as the last line

Disable WiFi Power Saving

Temporary

sudo iwconfig wlan0 power off

(or)

sudo modprobe -r ath9k
sudo modprobe ath9k ps_enable=0

Permanent

sudo touch /etc/modprobe.d/ath9k.conf
sudo scratch-text-editor /etc/modprobe.d/ath9k.conf

Add options ath9k ps_enable=0 as the last line

  • Thanks for the information! I tried the last suggestion, but found out that there was no ath9k.conf file there... So I created a new file, added the last line, but that has no effect so far. :( The power saving option in iwconfig is off by the way. Is a .conf automatically loaded at boot, or is there something more I need to do? – Robert van der Elst Sep 2 '15 at 5:14
  • Ah yes sorry I should have mentioned the file may not exist. Edited. Yes it is fine to create it. It doesn't really matter what you call it so long as it ends with .conf. The system parses ALL files in /etc/modprobe.d/ on boot and applies any options to the modules listed when they are next loaded. – elmato Sep 2 '15 at 11:49
0

I was having similar problems and it was because of my wifi card (realtek) and the drivers out of date. you should check your wifi card (lshw -c network) and then search the web if that is having drivers problem or something.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.