0

Getting this error even after installing packages manually as the depends warning continues.

Packages installed :

  1. libgegl-0.3-0
  2. libumfpack5.7.1
  3. libcholmod3.0.6
  4. liblapack3
  5. libgfortran3

On installing libgfortran3 the error is :

The following packages have unmet dependencies: libgfortran3 :Depends: 
gcc-5-base (= 5.3.1-14ubuntu2) but 5.4.0-6ubuntu1~16.04.9 is to be installed

E: Unable to correct problems, you have held broken packages.

But when I try to install gcc-5-base I get :

sudo apt install gcc-5-base
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gcc-5-base is already the newest version (5.4.0-6ubuntu1~16.04.9).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Unable to understand and get pass this.

1

libgfortran3 depends on gcc-5-base version 5.3.1-14ubuntu2. But you have version 5.4.0-6ubuntu1~16.04.9. Downgrading gcc-5-base to required version should solve your problem.

To downgrade to required version, run this command.

sudo apt install gcc-5-base=5.3.1-14ubuntu2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.