0

So, I have the RTL8723BE problem. I tried to fix it. I downloaded rtlwifi and installed it (success), but at some point, I lost my wifi connection. Then, i got the "modprobe: ERROR: could not insert 'rtl8723be': Required key not available" so i followed this instructions. It all went well until i got to this part:

sudo /usr/src/linux-headers-$(uname -r)/scripts/sign-file sha256 ./MOK.priv ./MOK.der $(modinfo -n rtl8723be)

which gave me this error

modinfo: ERROR: missing module or filename.
Usage: scripts/sign-file [-dp] <hash algo> <key> <x509> <module> [<dest>]
scripts/sign-file -s <hash algo> <x509> <module> [<dest>]

Because of that error I did not continue, because I imagine it's useless. What can I do?

  • You shouldn't need rtlwifi-new if you have kernel 4.4 or newer – Jeremy31 Jun 28 '18 at 10:35
  • @Jeremy31 I just checked and I have kernel 4.13. Should I just update it? (And would any ubuntu "tutorial" work for that?) – Julia Sepúlveda Jun 29 '18 at 16:48
  • Lol i've just realised the first number is not what counts the most hahaha. So, now that I know I have a newer kernel than 4.4, what kind of solution should I try? – Julia Sepúlveda Jun 29 '18 at 17:24
  • Ok so great, now it works, I don't know why, but it works. Thanks I guess? – Julia Sepúlveda Jun 29 '18 at 17:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.