0

Date: June 12ish-13ish, 2018 update.
Suspected Cause: Kernel update from 4.13.0-43 to 4.13.0-45

Have a Thinkpad T420 and just updated today. Tried watching a Youtube video and noticed my dedicated volume buttons no longer work and I had no sound. Same goes for mute speakers button and mute mic button. I can get audio to output but I have to go up and toggle on the on/off rocker and manually adjust volume from top menu bar, but only system sounds are heard nothing from the browser. What is even stranger is that when I go into sound settings it shows no output or input devices! Any advice?

0

I completely removed a pulseaudio mod I installed last year and also completely purged all the audio drivers.

I then installed aptitude based on some recommendations and used that to reinstall all the stock ubuntu audio drivers using --purge along with reinstall. Still after that I had no sound.

The key was running this command and rebooting:
killall pulseaudio; rm -r ~/.config/pulse/* ; rm -r ~/.pulse*

I stole that code from the ubuntu help page at: https://help.ubuntu.com/community/SoundTroubleshootingProcedure.

If anyone else has problems hope this helps. I still cannot use the dedicated volume buttons on my keyboard. I'll work on that soon, at least my speakers work now.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.