0

I want to disable ipv6 via sysctl.conf but it looks like the values are somehow being overridden for some interfaces.

ipv6 should be disabled:

$cat /etc/sysctl.conf /etc/sysctl.d/* | grep disable_ipv6          
net.ipv6.conf.all.disable_ipv6=1
net.ipv6.conf.wlp4s0.disable_ipv6=1
net.ipv6.conf.enp0s25.disable_ipv6=1
net.ipv6.conf.default.disable_ipv6=1

But it is not: some values are 0 and not 1 as expected (see below)! My ipv6 address is indeed visible on e.g. https://test-ipv6.com/ until I run sysctl -p.

$sysctl -a | grep disable_ipv6
# editing out some "permission denied" messages
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.enp0s25.disable_ipv6 = 0
net.ipv6.conf.lo.disable_ipv6 = 1
net.ipv6.conf.tun0.disable_ipv6 = 1
net.ipv6.conf.wlp4s0.disable_ipv6 = 0

How can I prevent that from happening? I currently have to run manually sysctl -p to actually disable ipv6.

I am using elementary OS 0.4.1 Loki.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.