2

I'm currently running elementary OS Loki and I have my monitor connected via Displayport 1.4

On other Linux distributions (Solus) I am able to play sound on my monitor.

On elementary OS, there is nothing to click in the Output section of the Sound setting.

When I type aplay -l this is what I see

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Any ideas?

Thanks!

0

You can install pavucontrol, more informations here

The next steps work for me:

  • Open a terminal
  • type alsamixer
  • with the card HDA ATI SB with chip Realtek ALC892, turn auto-mute to disabled.
  • After that i'd install Pulse Audio Volume control.

$ sudo apt install pavucontrol

  • Open it Pulse Audio Volume Control
  • In Configuration tab you can see the ATI HDMI Digital Setereo and Internal Audio.
  • Select to Internal Audio: Stereo Analog Duplex (Estéreo analógico duplex).
  • In Pulse Audio Volume, select Ouput devices, and for Internal Analog Stereo select: analg headphones.

Important: You must have installed the ATI drivers first. D Atonaltzin


System information

  • Motherboard Gigabyte GA-880GM-USB3 (realtek ALC892 audio integrated)
  • AMD Phenom II
  • 4GB RAM
  • Ati Radeon RX460 2GB graphics card.alsamix
| improve this answer | |
  • If I go to the configuration tab inside Pulse Audio Control, every option says (unplugged) to the right of it – DanMossa Jun 22 '18 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.