0

anyone found a way to keep nVidia's Powermizer settings to stick to Performance Mode between computer restarts?

If I select it from nVidia Settings GUI it always reverts to Auto Mode between computer restarts.

I want it to stay in Performance Mode.

Already tried adding options to device section of the xorg.conf:

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
    Option  "Coolbits" "13"
    Option  "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefaultAC=0x1"
EndSection
0

Managed to find a workaround:

Changing performance modes is possible through terminal with the following command:

nvidia-settings -a [gpu:0]/GpuPowerMizerMode=1

where:

0 - adaptive mode

1 - max performance mode

2 - auto mode

Now you can just create a small startup script (like for many workarounds in Linux). Just create a yourscriptname.desktop file under ~/.config/autostart and fill it with:

[Desktop Entry]
Type=Application
Exec=nvidia-settings -a [gpu:0]/GpuPowerMizerMode=1
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name=powermizer-maxperformance-autostart
Comment=Ustawiamy GPU na poziomie najwyższej wydajności
X-GNOME-Autostart-Delay=5

To test if it is actually working open nVidia Settings GUI and check Powermizer.

Alternatively issue a command in the terminal and check the output:

nvidia-smi --query-gpu=pstate --format=csv

P0 - max performance

...

P12 - min performance

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.