0

I'm on elementary 0.4.1 Loki and I run Telegram Desktop. The only way I can get the special characters such as é or ã on Telegram Desktop is to run with this command:

QT_IM_MODULE=xim Downloads/Telegram/Telegram

So I made a shortcut for starting telegram with special characters, but it just doesn't work. Other shortcuts work fine but this one wont start. What am I doing wrong?

1

Do you need to put the whole code here.

[Desktop Entry]
Version=1.0
Name=Telegram Desktop
Comment=Official desktop version of Telegram messaging app
Exec=env QT_IM_MODULE=xim /opt/Telegram/Telegram -- %u
Icon=telegram
Terminal=false
StartupWMClass=TelegramDesktop
Type=Application
Categories=Network;InstantMessaging;Qt;
MimeType=x-scheme-handler/tg;
X-Desktop-File-Install-Version=0.22

But you need to delete the TryExec line, otherwise it will not open.

But this is a palliative. Other applications running on QT will need extra settings. Try to do the following:

setxkbmap -model abnt2 -layout br -variant abnt2

And:

sudo printf 'XKBMODEL="pc105"\nXKBLAYOUT="br"\nXKBVARIANT="abnt2"\nXKBOPTIONS=""' > /etc/default/keyboard

And reboot. This should resolve permanently. Then tell me if that solved it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.