1

I'm brand new to eOS, but I've used other linux distros before.

I have installed Gdebi ok.

My problem is that Gdebi isn't working properly when I run it after clicking on a file in Files explorer and run 'Open With' an error box appears- "unable to open files or uris with this app".

It installs everything ok if run from within Applications- it's UI finds, opens and installs without issue.

Is the problem with the installation of Gdebi ( I've reinstalled several times), or with Files? I've tried different .deb files so an isolated corrupt .deb file is not the issue.

Thanks for any help available.

2
0

I had the same problem. For quite some time, I used another application called Eddy available on the AppCenter. However, I had some issues with dependencies.

If one doesn't have enough knowledge of dpkg and apt, I'd still suggest using 'GDebi.' I don't know why the GUI front-end gives problems in Elementary OS. I guess this is because if you open GDebi from a regular user account, it freezes since it is somehow prevented from asking sudo permissions.

My solution is to run GDebi from command line under sudo, that is

sudo  gdebi  path_to/file.deb

I never had issues with this approach.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.