0

I reinstalled eOS three weeks ago, now using 0.4.1. My system setup and partitions are same as before.
From last week my applications are taking long time to load. Copy/paste operation is very slow, not more than 10MB/s, previously it used to be like 70MB/s. My laptop is not very old, it just 3 years old with 4th generation i5 and NVIDIA 820M with latest driver installed.
Currently system is booting with Linux kernel 4.13, I tried booting with v4.11 but there was no difference.
Also I tried to decrease my boot time using e4rat; did it create this problem? I don't know.
I don't know what cause this problem, so I am here to ask possible solutions to debug this problem. Please let me know if you think something is causing this issue. Thanks

0

I found the bug myself. And the problem is very specific to my setup, the geek setup.
I have two partitions, one for root (/dev/sda1) and another for backup (/dev/sda2). backup drive was mounted in /media/backup.
Root was formatted with ext4 and backup was formatted with xfs file system.
Now the tricky part, I mounted /home/edward on /media/backup/edward. The fstab entry looked like:

/media/backup/edward  /home/edward  none  defaults,bind  0  0

This setup was causing the slow down after I logged in. But up until I see login screen my system was booting in 30 seconds which is normal for my hardware. This hinted me that there must be something wrong with my home folder.
Then I logged in my guest account and saw that programs are loading just fine without much delay. Home account of guest user is made in /tmp folder which is on same partition as of root /. This is what hinted me that mounting a folder of ext4 partition in folder xfs partition is causing the issue.

How I solved the issue, for now, is by moving my home folder back to partition of root.

Conclusion: mounting a folder of one type of file system (ext4) in folder of another (xfs) seems to be slowing down the system

0

There is a lot of things that can cause this problem. Could you give more details like when did this problem first occur?

  1. Did you install a new APP?
  2. Do you have a hard drive or Solid State Drive. If you have an SSD is trim turned on.
  3. Are you Maxed out on RAM? "Can be used when transferring data depending on setup."
  4. Are you transferring Files to External storage or the Same Drive? If external are you using USB 2.0 or 3.0.
  5. If you have a HDD is it making a slight noise. If so a head can be dragging on a platter and you drive is about to die.

Please give as much detail as you can. We can Figure this out together as a comunity. It could be as simple as an update or as bad as getting a new hard drive.

(ADVICE AS A USER- BACK UP DATA NOW, JUST IN CASE ANYTHING HAPPENS)

  • Please add this as a comment to the question, since it is not an answer on its own. – Cassidy James Aug 7 '18 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.