0

I have a fresh install of elementary os and I cannot connect to wifi. Only way to access internet is through LAN. I found similar problems on this forum but none of them could fix my problem.

some of the commands outputs are as below

uname -r

Output

4.13.0-32-generic

ifconfig

Output

enp2s0 Link encap:Ethernet HWaddr 48:ba:4e:af:44:2d
inet addr:192.168.1.7 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::8955:f56a:c8a0:993/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:3925 errors:0 dropped:0 overruns:0 frame:0 TX packets:3570 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:3336376 (3.3 MB) TX bytes:627742 (627.7 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:1038 errors:0 dropped:0 overruns:0 frame:0 TX packets:1038 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:114664 (114.6 KB) TX bytes:114664 (114.6 KB)

rfkill list

Output

0: hci0: Bluetooth Soft blocked: no Hard blocked: no

lspci

Ouput

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1576 00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Device 1577 00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Device 98e4 (rev da) 00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 15b3 00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 157b 00:02.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 157c 00:02.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 157c 00:02.4 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 157c 00:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 157b 00:08.0 Encryption controller: Advanced Micro Devices, Inc. [AMD] Device 1578 00:09.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 157d 00:09.2 Audio device: Advanced Micro Devices, Inc. [AMD] Device 157a 00:10.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB XHCI Controller (rev 20) 00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 4b) 00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD] FCH USB EHCI Controller (rev 49) 00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 4b) 00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 11) 00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b0 00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b1 00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b2 00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b3 00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b4 00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 15b5 01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330] (rev ff) 02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15) 03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d723

iwconfig

Output

enp2s0 no wireless extensions. lo no wireless extensions.

0

If you are using windows PC, you need to reset your wireless adopter, by going into control panel select network and wireless-properties and reset that will do the job

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.