3

the result of gnome-control-center keyboard

I'm trying to open the keyboard settings from the System Settings app, and the app just closes down. Every other item opens just fine.

elementary os 0.3 freya

Linux 3.16.0-38-generic x86_64

Please let me know what other info I can provide. I don't know what details will be helpful in troubleshooting.

2

Have you installed elementary-tweaks per chance? (I see Tweaks.vala in your terminal output) Unfortunately while a great application, it is reported to cause issues and is not recommend. This might be one of those issues? Try uninstalling it and see if the problem persists. If that fixes it I'd suggest posting a bug to the elementary-tweaks bug tracker.

Edit 1:

Just for clarification, gnome-control-center is a bash script that redirects to switchboard, which is the actual name of the System Settings app in elementary OS.

Upon further inspection of your terminal output, it shows a segfault on line 20, which is where the redirection takes place. The actual command to open the keyboard settings dialog is switchboard keyboard. Run that command directly and see if it gives any additional clues. If there is nothing obvious there, run it with the -d flag to show additional debug information. switchboard -d keyboard.

You could try to reinstall switchboard and the keyboard plugin with-

sudo apt-get update
sudo apt-get install --reinstall switchboard switchboard-plug-keyboard

If a reinstall doesn't help, it is time to hit the switchboard-plug-keyboard bug tracker. See this answer for best practices in lodging bug reports. I notice there are several existing bugs related to crashing on there already that may be possible duplicates of yours.

Please update your question with the -d output and a link to the bug report. Also consider including a link to this question in your bug report in case someone else comes along and solves your problem here.

  • Hello @elmato, I uninstalled elementary tweaks and tried the terminal command you suggested. I'm still getting the same behavior in system settings. The new output in the terminal is: [_LOG_LEVEL_INFO 18:05:45.656706] Application.vala:155: System Settings version: 2.0 [_LOG_LEVEL_INFO 18:05:45.656756] Application.vala:157: Kernel version: 3.16.0-38-generic /usr/bin/gnome-control-center: line 20: 2526 Segmentation fault (core dumped) switchboard $switchboard_options $requested_plug – Jason Aug 25 '15 at 23:08
1

enter image description here

I had the same problem, and this worked for me. Clicking that will reset the monitor config to default

Notice the key file contains key "Monitor" in group "PlankDockPreferences" in your terminal output? I'm not sure, but I am guessing it's because I sometimes plug in a 2nd monitor and I shift the displays around and Tweaks is trying to save it. After I unplug the monitor the configurations causes an error and quits.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.