0

I have installed Eclipse Oxygen from snapcraft (also attempted with the download from the official site). Eclipse launches, gets to about 25% complete on the load, and then elementary OS crashes, I lose all control over the system and I have to power-cycle my computer to restart. Is there any way to fix this?

  • elementary OS version: 0.4.1 Loki
  • Eclipse version: Oxygen 4.7.3a
2

I had similar problem. I solved it with editing eclipse.ini file:

Go to ~/eclipse/java-/eclipse/eclipse.ini

Open eclipse.ini with your favourite text editor.

Add

--launcher.GTK_version

2

Before "--launcher.appendVmargs”

Save and try starting eclipse. : - )

3
  • Thank you this really worked I have been trying to get this to work for over 2 weeks.
    – ExZiByte
    May 13 '18 at 20:34
  • Great to hear that! :)
    – Dysproz
    May 14 '18 at 18:21
  • Unbelievable this issue still exists more than 5 years later! JS version 6.6.0 I had to adjust /opt/tibco/TIB_js-studiocomm_6.6.0/Jaspersoft Studio.ini and add the fix on the 3rd line. I was'nt running into fatal issues, but all window decorations where double causing the main dialog buttons to be unusable
    – 4levels
    Oct 16 '18 at 8:31

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .