I recently tried to use elementary OS on my ThinkPad T420. Most of the hardware worked just fine out of the box: wifi, sound, graphics, etc. However, battery life on elementary OS has been very, very bad! It lasts about an hour at most. I have installed and enabled TLP, but it doesn't seem to make any difference.

The same laptop on Solus, Ubuntu or Mint lasts around 3 hours, and on Windows around 4 hours.

I tested the system by browsing the web on Firefox/Chromium, some light app installing, and general OS exploring. Nothing demanding has been ran when I tested the battery life.

Any thoughts?

3 Answers 3


I've had issues with battery life before, and every time it turned out to be a faulty install. Try reinstalling the OS and it should fix the issue. Elementary doesn't use any different drivers battery-wise than Ubuntu and if you have no problems on there, you shouldn't have any problems on elementary either.


thanks for the tip.

I reinstalled it and the issue remains the same. I left powertop running for a while, check the info below:

PowerTOP 2.8      Overview   Idle stats   Frequency stats   Device stats   Tunables                                     

The battery reports a discharge rate of 11.2 W
The estimated remaining time is 1 hours, 9 minutes

Summary: 767.5 wakeups/second,  0.0 GPU ops/seconds, 0.0 VFS ops/sec and 21.2% CPU use

                Usage       Events/s    Category       Description
             1993 rpm                   Device         Laptop fan
             50.2 ms/s     139.7        Process        /opt/google/chrome/chrome --type=renderer --field-trial-handle=14154079299553752411,6608151803463361335,131072 --se
              4.3 ms/s     132.1        Timer          hrtimer_wakeup
             16.6 ms/s      83.4        Process        /opt/google/chrome/chrome
             11.8 ms/s      75.6        Process        /opt/google/chrome/chrome --type=gpu-process --field-trial-handle=14154079299553752411,6608151803463361335,131072 -
              8.5 ms/s      60.1        Process        gala
              2.1 ms/s      61.4        Timer          tick_sched_timer
             15.3 ms/s      54.8        Process        /opt/google/chrome/chrome --type=renderer --field-trial-handle=14154079299553752411,6608151803463361335,131072 --se
             77.9 ms/s       7.7        kWork          intel_atomic_commit_work
              1.1 ms/s      21.6        Interrupt      PS/2 Touchpad / Keyboard / Mouse
              7.8 ms/s      16.5        Process        /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
            213.5 µs/s      19.7        Interrupt      [28] iwlwifi
              1.5 ms/s      16.9        Interrupt      [25] i915
            171.6 µs/s      13.6        Process        [rcu_sched]
              1.5 ms/s       9.5        Interrupt      [7] sched(softirq)
            343.8 µs/s       8.7        Process        [irq/28-iwlwifi]
            221.0 µs/s       7.1        kWork          ieee80211_iface_work
             48.7 µs/s       6.9        kWork          console_callback
            105.9 µs/s       5.9        Process        [i915/signal:0]
            410.1 µs/s       3.9        Process        /usr/sbin/acpid
             70.9 µs/s       2.9        kWork          iwl_bg_run_time_calib_work
              1.6 ms/s       1.7        Process        /opt/google/chrome/chrome --type=renderer --field-trial-handle=14154079299553752411,6608151803463361335,131072 --se
            428.2 µs/s       2.0        Process        wingpanel
            385.4 µs/s       1.5        Process        plank
             20.6 µs/s       1.5        kWork          intel_atomic_helper_free_state_

            297.6 µs/s       0.8        Process        /usr/lib/x86_64-linux-gnu/bamf/bamfdaemon
              1.4 ms/s       0.4        kWork          disk_events_workfn
             20.8 µs/s       0.9        kWork          iwl_pcie_rx_allocator_work
              1.0 ms/s       0.4        kWork          i915_gem_idle_work_handler
            187.5 µs/s       0.7        Interrupt      [4] block(softirq)
            309.1 µs/s       0.6        Process        pantheon-terminal
            264.5 µs/s       0.7        Process        /opt/google/chrome/chrome --type=renderer --field-trial-handle=14154079299553752411,6608151803463361335,131072 --se
             16.8 µs/s       0.7        kWork          vmstat_shepherd

By the time I left it run and posted this (10 min of usage), I lost around 15% of battery :(

  • Reinstalled the OS again and the issue persists.
    – Xamineh
    Commented May 6, 2018 at 9:31

This could easily depend on whether your model has an Optimus GPU installed - power management for that's notoriously poor.

Otherwise, look to the usual suspects for a T-series Thinkpad; TLP or Thinkfan. Go & check out thinkwiki for the T420 it's your go-to place for Thinkpad tips.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.