0

Put a new SSD in my old Dell Inspiron 3520, and although my wireless connected just fine from the version of Loki on the USB stick and appeared to install everything perfectly, when I reboot I have no wireless access or even detection of a card by network settings. When I plug in an ethernet cable it says I'm connected, but it can't identify an access point and I can't get online. But lspci shows both the wireless (Broadcom BCM43142) and ethernet cards. What's going on?

  • 1
    Update: Ethernet works now, wireless still doesn't. I put my old HD in an external case and booted up from it, and as always my wireless (card is Broadcom BCM43142, a.k.a. DW1704) works fine. By installing the latest version of Elementary OS have I deployed a kernel that doesn't work with my wireless device? – Jeff May 1 '18 at 23:47
2

Please go to AppCenter() over an Ethernet connection and click on the installed tab. If you see bcmwl-kernel-source, install it by clicking on free. Your WiFi() should be working again.

  • This works. But it's so strange that everything works out-of-the-box in the live version, then you install and make sure that also third-party code can be installed, and after the install you're left with broken wifi. Lucky those with computers that still have Ethernet. – berliner Jun 13 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.