1

I'm having issues with anything considered a "media key" in dconf -> org -> gnome -> settings-daemon -> plugins -> media-keys

I've tried assigning shortcuts to things like terminal, volume up/down, etc in both dconf and settings -> keyboard -> shortcuts. Regardless of the short-cut combination I use, these keys just do not work.

I'm running Loki 0.4.1 on my mid-2015 Macbook Pro.

I've checked my key names using sudo xbindkeys -k and have used these names in dconf. I've also tried simply pressing the key in Elementary's keyboard shortcut settings section. Neither of these work, the shortcuts simply do nothing.

I also tried using the gsettings commands to change the shortcuts, no luck.

It's really quite frustrating, especially for things like volume, screen brightness etc. I'm running the same version of ElementaryOS on my Surface Pro 3 and all media keys work well, so it's just the MBP :(

On a side note, the function keys F1-F12 work perfectly when holding fn, these are the same physical keys as most of the media keys, so the actual keys aren't busted or anything. I've also tried changing the shortcuts for volume down to something basic like Alt+E but the result is the same, volume doesn't change.

Any help would be appreciated.

Edit: This was resolved in Juno

  • If you install evtest sudo apt-get install evtest then run sudo evtest, choose your keyboard from the list, and then press a media key like volume up, do you get something like a KEY_VOLUMEUP event? – santileortiz May 3 '18 at 4:15
  • @santileortiz Hi, yes that's exactly what I get: KEY_VOLUMEDOWN, KEY_MUTE etc. – J. Afarian May 3 '18 at 5:01
  • That means the driver is working fine, so the problem is in some layer above. What happens if you go to Settings->keyboard->media and assign a shortcut like ⌘ + V to Volume Up?. Does that work? – santileortiz May 12 '18 at 4:05
  • @santileortiz No it doesn't. I can't assign even basic key combinations to the media keys :( – J. Afarian Jun 4 '18 at 1:31
  • @j-afarian hey! elementary OS Juno Beta has just been released publicly (developer.elementary.io/#beta), could you try a live USB of it and see if the problem is still there? – santileortiz Jul 5 '18 at 6:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.