2

Need to get 0 B/4,464 B of archives. After this operation, 16.4 kB of additional disk space will be used. Selecting previously unselected package pantheon-terminal. (Reading database ... 344254 files and directories currently installed.) Preparing to unpack .../pantheon-terminal_0.4.3+r1069+pkg51~daily~ubuntu16.04.1_amd64.deb ... Unpacking pantheon-terminal (0.4.3+r1069+pkg51~daily~ubuntu16.04.1) ... Processing triggers for man-db (2.7.5-1) ... Setting up pantheon-terminal (0.4.3+r1069+pkg51~daily~ubuntu16.04.1) ... update-alternatives: error: alternative path /usr/bin/io.elementary.terminal doesn't exist dpkg: error processing package pantheon-terminal (--configure): subprocess installed post-installation script returned error exit status 2 Errors were encountered while processing: pantheon-terminal E: Sub-process /usr/bin/dpkg returned an error code (1)

  • Having the same, have purged with apt, purged with dpkg, reconfigured and cleaned. Can't install – Dave Mackintosh Apr 11 '18 at 8:01
  • I solved it, this is what I did: 1. Remove the daily repository "sudo add-apt-repository --remove ppa:elementary-os/daily". 2. "apt-get update", 3. Remove pantheon-terminal and reinstalled it with apt-get. 4. apt-get upgrade. 5. Verify if another daily package is installed on the system, lucky for me it was just pantheon-terminal. – Ernesto Arias Apr 12 '18 at 4:57
  • I tried all that, I'll just have to live without. – Dave Mackintosh Apr 16 '18 at 7:56
  • Dave make and apt-get update and apt-get upgrade after remove the daily repository. – Ernesto Arias Apr 17 '18 at 9:09
  • What I did in the end was removed the daily PPA (I forgot it was a daily) and I added the stable channel for xenial (I'm on 17.10) and it installed perfectly fine. – Dave Mackintosh Apr 17 '18 at 15:11
1

I'm just trying to get to the bottom of this in case more people see this issue. This answer is a bit haphazard.

The problem seems to be that the apt package doesn't have the file /usr/bin/io.elementary.terminal in it anymore.

To check for yourself, install aptitude, and run this in another terminal program:

aptitude download pantheon-terminal

The file will be ~4kB. You can open it in archive manager to investigate further. Inside, in the data portion, there's only /usr/share/doc/and /usr/share/man/

This only seems to happen when on the daily elementary PPA, which I don't know how it would be configured that way in the first place.

As you point out in a comment, to fix it you will need to change your package source by removing the daily ppa and adding the stable one.

How to fix it:

You will need access to a terminal. You can press Ctrl-Alt-F1 to access one at tty1 (Alt-F7 to return to your desktop afterwards), or install another from App Centre.

First purge the pantheon-terminal files from your system:

sudo apt purge pantheon-terminal

Then remove the daily ppa like this:

sudo apt add-apt-repository --remove ppa:elementary-os/daily

Then add the stable repository to your sources:

sudo add-apt-repository ppa:elementary-os/stable

Now you can update and install the terminal again:

sudo apt update
sudo apt install pantheon-terminal

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.