7

When I click with the middle button of the mouse on a window, it goes to the bottom of the stack, and two clicks on the window bar maximize it. Can we change that? or even disable?

some background:

I use the middle click to paste content on a new tab on chrome, middle clicking the new tab button, but it's easy to miss it and put your browser on the bottom of the stack, it is annoying

  • @tim I would like to disable the middle-click putting the window on the bottom – igrossiter Jul 2 '15 at 15:49
11

You can use gsettings:

gsettings set org.gnome.desktop.wm.preferences action-middle-click-titlebar 'none'

Will disable the feature. To re-enable, use this:

gsettings set org.gnome.desktop.wm.preferences action-middle-click-titlebar 'lower'

These are the options you can set it to:

  • toggle-shade, which will shade/unshade the window (roll up / down)
  • toggle-maximize which will maximise/unmaximise the window
  • toggle-maximize-horizontally and toggle-maximize-vertically which will maximise/unmaximise the window in that direction only
  • minimize which will minimise the window
  • shade which will roll the window up
  • menu which will display the window menu (default for right click)
  • lower which will put the window behind all the others
  • none which will not do anything, and effectively disables this action.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.