4

Every so often, I get the following popup in Elementary OS:

"Authentication is required to refresh the system sources"

I enter my SUDO password, but it won't take it. What password do I use? Is this just a bug?

Thanks!

Jim elementary OS 0.4.1 Loki

  • I'm experiencing the same behavior on a fully up to date instance of Loki. On returning to a desktop which has been unattended all night, after login i am presented with the prompt to enter credentials to update system sources. My sudo password is rejected. I have no problem closing the prompt window & no other issues with the system (e.g., app store / apt-get updates etc) have any issue with my credentials. – user1943819 May 26 '18 at 12:58
1

I ran all updates from the Terminal window, rebooted, and now I can access the shared drive. Perhaps something had gotten stepped on, and an update fixed it.

Hopefully this has fixed the other issue as well (the "Authentication is required" prompt).

Update: The "Authentication is Required to refresh the system sources" window popped up again. Problem not yet solved.

0

I saw the same after installing updates. I performed another reboot and the popup is now gone.

  • The popup doesn't happen very often - maybe three times per month. And I have rebooted, yet the popup returns a bit later. So far, all I can do is close the popup by hitting the 'x'. I thought about installing updates - not from the Updates icon, but from the terminal; in other words, all available updates. That fixed an issue I had on my Mint computer. I'll try that. Thanks for the suggestion. – MrJimPhelps Apr 6 '18 at 20:02
0

Mine returned as well. I reviewed the Other Software tab in Software & Updates and removed the check mark for the freerdp2 repository I had added. Since that time (almost a week now) I have not seen the request for credentials. Take a look at your entries and try removing the check mark for any that are not default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.