0

I followed the instructions here How to install nvidia graphics driver for nvidia 820m on loki? however if I run

sudo prime-select nvidia
glxgears 

I get

X Error of failed request:  BadValue (integer parameter out of range for    operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  23
  Current serial number in output stream:  24

I'm using a dell xps 15z and lspci | grep 'VGA\|3D'outputs

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
02:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)

I've been trying different things for a while and am stumped.

0

The problem was actually something obvious. I failed to turn off secure boot correctly. I always thought it was odd that I never seemed to have to enter the password I set, not realizing I was passing over the spot to do it while booting. The windows was so small on my screen to barely be legible. When I did enter the password instead of pressing enter and passing over the prompt the drivers worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.