0

I've installed element OS on my SSD(120GB) and now I'm not able store data in hard drive(1TB)

If tried to mount was getting this error.

Error mounting /dev/sda2 at /media/kamalnrf/LENOVO: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda2" "/media/kamalnrf/LENOVO"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Failed to mount '/dev/sda2': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.

  • 1
    Have you tried what it suggests? Start windows and shut it down again properly. – David Hewitt Mar 30 '18 at 23:28
1

You can always try to fix the drive. Try this:

sudo ntfsfix /dev/sdXY

Where "X" is the drive and "Y" is the partition (on an NTFS partition). It should work some magical incantation in the background for you and when it's done you should have a mountable NTFS drive.

So in your case, try this:

sudo ntfsfix /dev/sda2

Please let me know if that helps any.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.