I am currently running of EOS in a virtual machine using VirtualBox on Windows. It has been working fine for a while, but this morning a little while after updating via the Appcenter, the GUI stopped working and just has a black screen with a blinking cursor in the upper left. I am able to log in using the TTY1 screen (terminal only) and that seems to work just fine. Rebooting doesn't resolve the issue.

Running the startx command doesn't seem to do anything. The screen just blinks and goes back to the terminal.

I also ran these commands:

sudo apt-get remove --purge libxfont1 sudo apt-get install libxfont1 xorg sudo rm ~/.Xauthority reboot

No change came from those either. I ran sudo apt-get install --reinstall elementary-desktop to no avail.

I also ran: sudo apt-get install --reinstall xorg

Finally I ran sudo apt autoremove and that didn't resolve the issue either.

  • I get the same problem since a couple day. I have made a new installed base on the latest ISO file elementaryos-0.4.1-stable.20180214. The installation runs fine and Elementary OS runs well until it require system update. When the system update are done the symptom appears at the next reboot. A black screen with a blink dash.
    – Windy
    Commented Mar 29, 2018 at 18:55
  • Are you running it through a virtual machine? Or did you install it on a bare drive? Commented Mar 29, 2018 at 23:14
  • Experiencing the same issue. Running on Windows 7 in VirtualBox v5.1.10. Reverting back to a 6 month old copy then updating it using sudo apt-get etc causes the same issue. Appears to be a UI issue. Anyone had any luck on this? Commented Apr 12, 2018 at 8:37
  • I believe it is something to do with the VirtualBox tools driver update. I just started a whole new VM from scratch and didn't install the VirtualBox drivers from the AppCenter, and all is good now. I'm on Windows 7 and VirtualBox version 5.2.8. tty1 works just fine, its just trying to get into the GUI that causes issue. Just a pure black screen with a blinking cursor in the upper left. Commented Apr 13, 2018 at 17:44

1 Answer 1


After a little bit of experimentation I found that the issue is related to the VirtualBox guest packages.

To allow the GUI to boot as normal and get back to your OS, you need to remove them as outlined below. Note that doing so will result in some VirtualBox functions being lost - the most prominent being bidirectional copy and pasting, and mouse highlight functions.

  1. Boot up machine in VirtualBox
  2. Wait for cursor blinking issue, then access tty1 using Ctrl + Alt + F1
  3. Log in as normal user
  4. Run the following three commands:

    sudo apt-get remove --auto-remove virtualbox-guest-dkms

    sudo apt-get remove --auto-remove virtualbox-guest-dkms-hwe

    sudo apt-get remove --auto-remove virtualbox-guest-x11

  5. Reboot using sudo reboot now

You should then see the GUI start and present you with your normal login screen.

It's worth noting that even after installing the latest version of VirtualBox in Windows, installing the latest guest utils and VirtualBox additions on Elementary, and ensuring everything else is up-to-date still causes the same problem, even on fresh install.

Unsure of exact cause of conflict when these are installed.

  • I'm running Elementary 5 @ VirtualBox 6 on Windows 10 and experience the same problem, but I don't have the extentions from apt installed. So this did not work for me.
    – thoni56
    Commented Jan 23, 2019 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.