0

I've been having quite the issue with getting 0.4.1 loki running on my razer.

The log in screen loads just fine, but after I input my password I see a fizz of static and the machine freezes. I have to do a hard reboot. I can get to a terminal from log in screen, and have checked drivers, tried using nouveau and nvidia drivers, no luck.

It has an Intel Core i7 7500U kaby lake with intel HD graphics 620 if that helps. I have found other users with this same problem, but no solutions that work for me.

  • Can you wait 10 minutes in that frozen screen? Maybe it continues working after that. – Maccer Mar 21 '18 at 15:12
0

I have a kby lake chipset, although on a Dell XPS 13, and it works fine for me.

First try sudo dpkg-reconfigure lightdm and try again sudo service lightdm restart

I did also upgrade the kernel (and you can try the ubuntu hwe - hardware enablement kernel as a first option - you can do it with apt), I did also install the kbl specific firware from Intel (you can tell it's worked when you upgrade kernel because there is no missing kbl firmware logged). You can also try fwupdmgr in terminal to see if there are any firmware updates available.

Nvidia drivers should not work, as it's intel graphics.

The intel stuff is here: https://01.org/linuxgraphics/downloads/firmware

They also have "recipes" on the site which suggest version of packages for a good intel Graphics stack. Can be worth trying.

0

I had the same problem on my Gigabyte Sabre 17. Go into your BIOS settings and disable 3d acceleration.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.