0

I've completely removed the stock OS on my new laptop and successfully reinstalled it with the latest Windows 10 64-bit (Redstone 4) MSDN ISO (erased all partitions, Win10 setup automatically recreated all necessary partitions,…). For that I've created a bootable USB flash drive using Rufus with NTFS file system and GPT partition scheme and that booted/installed perfectly fine.

Now I want to make a Windows/Linux Dual-Boot system and tried to boot from the elementary OS live USB but that failed everytime. I've tried all latest Ubuntu dereviate distro's, 64- en 32-Bit, ... but always the same negative result, a black screen with a white (non-blinking) underscore.

In UEFI I can perfectly set the boot priority to the preferred USB (it’s nicely detected as UEFI boot USB) but when it tries to boot from that it always gives me a black screen with a white (non-blinking) underscore. I've tried secure boot enabled/disabled,... but always the same negative result.

I use a 2GB USB flash drive, formatted with latest Rufus in FAT32 file system en GPT partition scheme. I've tried all possible file system/partition schemes combinations, different USB flash drives,... but always the same negative result.

I also tested the USB's on my other (UEFI) laptop and they all booted perfectly fine. The linux GRUB isn't loading at all on my new laptop and it seems like UEFI doesn't detect the USB UEFI partition scheme at boot (disabled by vendor? system to new for Ubuntu? perhaps some graphics issues?)

It always gives me a black screen with a white (non-blinking) underscore :/

I searched like crazy for solutions on google and the manufacturer website with no results. Is there someone that can throw a light on this matter please?

I really would like to use elementary OS on my new laptop (Medion Akoya E3213T)

Some hardware reports from AIDA64 (Win 10):

Computer Type ACPI x64-based PC / Operating System Microsoft Windows 10 Home / OS Version 10.0.17134.48 (Redstone 4) / CPU Type DualCore Intel Celeron N3350, 2400 MHz / Chipset Intel Apollo Lake / System Memory 2048 MB / Video Adapter Intel HD Graphics 500 / Video Resolution 1920 x 1080 @ 60 Hz / Monitor ID AUO272D / Audio Adapter Intel Broxton HDMI @ Intel Apollo Lake SoC / Audio Adapter Realtek ALC269 @ Intel Apollo Lake SoC / IDE Controller Standard SATA AHCI Controller / Disk Drive Toshiba 064G38 (64 GB eMMC) / Keyboard HID Keyboard Device / Keyboard Standard PS/2 Keyboard / Mouse HID-compliant mouse / Network Adapter Intel(R) Dual Band Wireless-AC 3165 / USB3 Controller Intel Apollo Lake SoC - USB 3.0 Host Controller (xHCI) / USB Device HD Camera / USB Device Intel(R) Wireless Bluetooth(R) / USB Device Realtek USB 2.0 Card Reader / USB Device USB Composite Device / BIOS Vendor American Megatrends Inc. / BIOS Type AMI EFI / BIOS Version V2.0.5_P2S0T1P1F3G2C2 / SMBIOS Version 3.0 / UEFI Boot Yes / System BIOS Date 07/25/2017 /

  • I have a similar laptop as yours :D Let me know if u fixed this :D Thanks! – Laurentiu Costache Apr 3 '18 at 17:43
0

Allot of (new) low end laptops and tablets ship with a 64-bit CPU, but 32-bit UEFI firmware implementation. It should be fairly possible to use a 32-bit UEFI grub build to boot a 64-bit kernel and distribution on these systems.

So far this setup has (sadly) not been supported in elementary OS (yet), which leads to many live-USB ISO boot problems/issues/questions/reports like this...

There are quite a few "older" 32-bit UEFI with 64-bit CPU systems out there to, so this should allow elementary OS to run on even more hardware. Some well known examples are: The Asus Transformer T100TA, HP Stream 7, Dell Venue 8 Pro 5830, the first Apple Intel Macs and many others.

I do know for sure that this solves the above problem, as when I try to boot from ANY live-USB, it ONLY works with Fedora 28 (64-bit) and the 64-bit Microsoft MSDN ISO's (they've added 32-bit UEFI support nicely).

For now, it looks like I have to wait for proper 32-bit UEFI support/implementation in (I hope) Juno.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.