1

I'm in the Starbucks and I couldn't connect to their free wifi, login page just wouldn't show up(any browsers).
I tried to direct to the login page by copying login link form my smartphone, but it didn't work, has anyone encountered this problem and solved it?
I found some Ubuntu users have this problem too. It's not only happening at Starbucks, I went to other places where needed to accept from a login page and couldn't connect as well.
I'm frustrated and typing this post by using my cellphone's mobile data.

1

When you try to connect to a wifi network that requires some sort of login page it will automatically show up. You just need to go to the wifi indicator, press over the network name and the window will appear after a while (it should take less than 5 min).


If that didn't work, you can try to delete the wifi network from System Settings > Network > Wireless > Edit Connections... and then do the whole process described earlier again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.