0

So, I just installed Elementary OS 0.4.1 Loki from a USB drive, and I couldn't get my Ethernet connection to work after installing with proprietary drivers, neither without them. Both were clean installs without anything else installed.

My motherboard is an ASRock N68-GS4 FX R2.0, featuring the Giga PHY Realtek RTL8211E. I couldn't find any drivers for this specific model on the Realtek website, and no Linux drivers at all over at ASRock's website.

I have no access to WiFi on this computer, so thats out of the question for troubleshooting (I'm writing this with Win7, I'm using dualboot).

Any help would be much apreciated.

  • Not really a solution, but I would recommend searching on Ubuntu in combination with your Giga PHY Realtek RTL8211E device. This since Ubuntu has many more users and since eOS is build on Ubuntu solutions will usually work on eOS too. – Peter Uithoven Mar 5 '18 at 10:20
1

Ok, apparently after looking for some specs on the ethernet controller, some questions about similar motherboards on hardware forums and then some questions on the Ubuntu forums, I could narrow down the issue to the "forcedeth" driver, attributed to the nVidia nForce part of my motherboard (I assume it is some sort of I/O controller, as it also controls onboard audio, hard drives and whatnot). [EDIT: This seems to be a problem on most, if not all, ASRock motherboards running AM3+ CPUs, so if thats your case, the following solution might work out for you.]

Here is the solution that worked for me: Booting into Recovery mode through GRUB. Then on the recovery options, I had to select GRUB to change my system from "read-only" to "read-write". Then I went on ROOT and did the following commands:

# rmmod forcedeth
# modprobe forcedeth msi=0 msix=0
# exit

And Ethernet is now working.

But, that only worked until I rebooted, so after a couple of hours looking into articles on my phone, I reached the following solution to make it so ethernet is working every time (also, I was having issues shutting down/restarting, those were fixed too).

Insert the following on terminal:

echo "options forcedeth msi=0 msix=0" | sudo tee /etc/modprobe.d/forcedeth_options.conf

Insert your password, and then

sudo update-initramfs -u

And bam, it is working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.