0

I'm running Elementary os 0.4.1 loki. After doing some magic with apt-get I managed to broke it so some packages won't install. Then I tried to fix it with some solutions I found on Google like apt-get clean && apt-get autoremove, apt-get install --fix-missing, dpkg --configure -a, etc.. Now almost every package says 'unmet dependencies'

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.6 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

...

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 pinta : Depends: libcairo2 (>= 1.14.0) but it is not going to be installed
         Depends: libglib2.0-cil (>= 2.12.10-1ubuntu1) but it is not going to be installed
         Depends: libgtk2.0-cil (>= 2.12.10-1ubuntu1) but it is not going to be installed
         Depends: libmono-addins-gui0.2-cil (>= 1.0) but it is not going to be installed
         Depends: libmono-addins0.2-cil (>= 1.0) but it is not going to be installed
         Depends: libmono-cairo4.0-cil (>= 4.0.4.1) but it is not going to be installed
         Depends: gnome-icon-theme but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

And apt-get update gives me this error at the end:

Err:20 http://ppa.launchpad.net/n-muench/programs-ppa/ubuntu xenial Release
  404  Not Found [IP: 91.189.95.83 80]
Reading package lists... Done                       
E: The repository 'http://ppa.launchpad.net/n-muench/programs-ppa/ubuntu xenial Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

And some programs won't start now

$ gimp
Gtk-Message: Failed to load module "pantheon-filechooser-module"

How do I fix it? Should I just reinstall the system?

  • Gtk-Message: Failed to load module "pantheon-filechooser-module" is just a warning and shouldn't matter. – Peter Uithoven Feb 22 '18 at 8:04
2

The "... does not have a Release file" part is quite common, looks like you have a ppa enabled / added that doesn't support Ubuntu Xenial, where elementary OS is build on. Please try to be careful when adding third party ppa's. Please try using newer packaging solutions like Snaps, Flatpacks or AppImages.

Looking at it's url http://ppa.launchpad.net/n-muench/programs-ppa/ubuntu this is the ppa: ppa:n-muench/programs-ppa.

If you can still install applications I would recommend using ppa-purge, to remove the ppa. It does extra things, like also uninstalling and downgrading packages coming from a ppa. (It will tell you what it will do, before yo confirm that's what you want)

sudo apt install ppa-purge
sudo ppa-purge ppa:n-muench/programs-ppa

If you can't install that package I would remove the ppa like:

sudo add-apt-repository --remove ppa:elementary-os/daily

I know, an add command, with a remove argument, it's bad, but works.

  • add-apt-repository got deleted after autoremove and I'm unable to install it with software-properties-common or python-software-properties or python3-software-properties – S. One Feb 22 '18 at 9:57
  • I was able to install ppa-purge, but output is: pastebin.com/c4VEumXW . Other packages still won't install – S. One Feb 22 '18 at 10:00
  • Alright... that might mean xenial has never been supported and there are no packages that need to be downgraded or uninstalled anyway. What's the output of attempting to install software-properties-common ? There might also be a way to remove it by removing the relevant file from /etc/apt/sources.list.d, but that's probably more error prone. – Peter Uithoven Feb 22 '18 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.