3

Recently I've added elementary OS as a dual boot to my Lenovo w540. On the windows 10 side, I can push a lot more volume out of the on-board speakers than from elementary OS. When I push the volume past 100%, the volume gets much closer to what I can get from windows. The only problem is, I need to go to the sound settings menu to do this. If I hit the volume up key, it will take the volume from 150% or whatever the max is down to 100%, or from 0% up to 100% but no further. Volume down key will increment down naturally from 150%, so only the volume up key is less than idea.

Is there any way to allow volume key to push volume levels past 100%?

2

So the ultimate solution to this, I was able to figure out how to assign the volume up key to a custom key combination. I used ctrl-alt-Audio Raise Volume to assign to this key. It will not give you a testing volume to show you how loud it is, but it will raise the volume past 100%. I could not figure out how to bind this to the original audio level up key.

Note I did install xbindkeys before I started, so this may have altered what you are about to see. First add a shortcut with the desired key combo through the original system settings -> keyboard -> shortcuts -> custom menu by clicking the little plus at the bottom. Call this whatever you would like.

Using the system settings, add a shortcut with desired key combo

After setting this up, open dconf Editor, and navigate to org -> settings-daemon -> plugins -> media-keys -> custom-keybindings -> custom0. For me it was custom0, but choose the index of the key binding you need to alter.

Once inside, you need to change the change the command to a version of pactl set-sink-volume 10 +10% that works for your computer. This is PACTL not PACT(one). The 10 is the device id for your audio system, on my computer it was actually 1. The +10% should raise your volume by that percentage, and take it beyond 100% volume if you have the appropriate sound settings box checked when you run this command.

The best way to accomplish this is to test your command in terminal and then copy paste it later. So copy the command so that the whole line is highlighted as in the image below, and keep that in your clipboard.

Testing the command in terminal while watching for volume change

After this, you'll need to go back into you dconf Editor window and change the command section of the shortcut for custom0. You need to paste so that when you paste, before hitting enter, there is a special character you can see following the command. Probably a representation of the '\n' newline character. Not 100% sure it's necessary, but this is what worked for me.

Special command seen after text for command

One of the things you'll also notice here is I bumped the % up to 750%. I found that when it executes as a key binding, it doesn't change the volume nearly as much per keystroke, so I had to adjust this to my liking.

I was also able to recover functionality of my botched default volume key through this menu in dconf Editor as well.

Hope this helps someone out there

  • 1
    Great job, Vince! Once you've made the changes in dconf-editor and rebooted, did the changes stick? – linux_tim Feb 20 '18 at 3:49
  • 1
    So far they have stuck. I've completely turned the computer on and off, booting into both the Windows 10 and the EOS of my dual boot multiple times and the change seems to stick. – Vince Feb 21 '18 at 3:56
1

I believe what you may be looking for can be easily accomplished by installing elementary-Tweaks then making an adjustment. Here are the commands to do so:

sudo apt-get install software-properties-common

Then, add a repo:

sudo add-apt-repository ppa:philip.scott/elementary-tweaks

Run update:

sudo apt-get update

Finally, install Tweaks:

sudo apt-get install elementary-tweaks

Now that you have "unlocked" software properties and installed Tweaks, you can open it by opening System Settings then click on Tweaks which is in the top "Personal" section. In Tweaks, click on Miscellaneous. This is where you can jack-up the Max Volume.

Again, I believe this is what you're looking for and be advised...this applies to Loki only.

Good Luck!!!

  • I tried this and this is not quite what I had in mind. The maximum volume is achievable through the typical menu, so achieving the maximum value is not an issue. Still hitting the volume up key (Shares with F3) will get me to a maximum of 100%. Is there a way to reassign the functionality of that key so it can move to the 150% mark? – Vince Feb 17 '18 at 19:07
1

pactl set-sink-volume $ID +10% to increase volume of sink id $ID by 10%. $ID can be found using pactl list sinks.

You can test it first from the terminal and if it works you can put the command in a simple script and set a custom shortcut to call it.

My pactl list sinks output is:

Sink #10
    State: Running
    ...

so my $ID is 10. If you have multiple audio card maybe you will have to choose one which you want to use.

increase-vol.sh:

#!/bin/bash
pactl set-sink-volume 10 +10%

Unfortunately I can't find any way to rebind the Volume Up key (or normally identified as XF86AudioRaiseVolume by the sytem).

  • Thanks so much! Getting this information should be a short ways away. I'll look into keybinding now to see if I can pair those up. This gives me the functionality I was looking for, even if it isn't directly connected to the key yet – Vince Feb 18 '18 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.